#blog2navi()

apt-get 恐るべし

turbo gearsが上手く入らないので、vine3.2にupgrade。apt-get update,upgradeで3.2になる。phpが4.4.2になったがほおって置いたら、pukiwiki-1.4.4_php5が上手く動かなくなる。しかたなく、pukiwiki-1.4.6にアップグレード。 blog2が上手く動かないが、なんとか修復。 pukiwikiのデータをコピーするスクリプト(無保証)

!/usr/bin/python
##copy.pyこのファイルをpukiwikiの親ディレクトリにおいて実行します。
import os,os.path,shutil
fromdir='./pukiwiki-1.4.4_php5' ##コピー元のディレクトリをしています。
todir='./pukiwiki-1.4.6'  ##コピー先のディレクトリを指定します
dir_name=('attach','backup','cache','counter','diff','trackback','wiki');
for name in dir_name:
	dirname=os.path.join(fromdir,name)
	for fname in os.listdir(dirname):
		fromname=os.path.join(fromdir,name,fname)
		toname=os.path.join(todir,name,fname)
##		print fromname,toname
		if os.path.exists(fromname):
			 try:
				 shutil.copy2(fromname,toname)
			 except (IOError, os.error), why:
				 print "Can't copy %s to %s: %s" % (fromname, toname, str(why))
: [unix] - 2006-03-26 12:30:34

&blog2trackback();

#blog2navi()


トップ   差分 バックアップ リロード   一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2015-02-01 (日) 14:38:24 (1725d)